このページの本文へ このサイトのメインメニューへ
現在地
ここから本文です

リコー センターサービス
WordPressでエラーが表示される場合

[サーバーのPHPバージョンは5.1.6ですがWordPress4.1.2は5.2.4以上のみでご利用になれます]とエラーが表示される場合は、Web管理画面よりPHPのバージョンアップが必要となります。
以下、手順の説明となります。

必要項目
・/httpdocs 直下に[.htaccess]という設定ファイルが必要となります。
・[.htaccess]初期記述のままの場合、PHPバージョン5.3.3にアップする記述を追記します。


No_001.jpg Web管理画面ログイン後、[ファイルマネージャ]での操作となります。
/httpdocs直下に[.htaccess]設定ファイルがある場合、[テキストエディタで編集]をクリックします。([.htaccess]設定ファイルが無い場合は新規作成します)
hta01.png


No_002.jpg 以下初期記述の内容だった場合、下記【PHP5.3.3へバージョンアップする場合の追記内容】を追記します。
hta02.png


PHP5.3.3へバージョンアップする場合の追記内容
記述内容は2種類ありますが、どちらかを追記します。
FTPソフトにより設定画面が異なります。必要に応じて内容を読み替えて設定をお願いします。


【fast-cgiとして動作させる場合】
AddHandler fcgid-script .php

【cgiとして動作させる場合】
AddHandler php53-script .php


[.htaccess]の初期記述内容
※不要なスペースが入らないようご注意ください。
FTPソフトにより設定画面が異なります。必要に応じて内容を読み替えて設定をお願いします。


Options +ExecCGI +IncludesNOEXEC
Allow from all
AddHandler cgi-script .cgi



No_003.JPG 追記完了しましたら[OK]をクリックします。
hta03.png